github에 블로그를 옮기기 전에 테스트 목적으로 로컬에 jekyll을 설치하려는데 오류가 발생하였고, 이 오류는 ruby를 업데이트하는 것으로 해결되었음.  단순히 static blog engine을 사용해보려고 한 것이었으나 아래 오류로 인하여 한 번도 사용해보지 않은 ruby, gem을 설치/업데이트 등을 하게 되어 배보다 배꼽이 더 큰 상황이 되어 버렸다.


# 오류

Mac OSX에 기본으로 포함된(?) ruby, gem 버젼에서 jekyll을 설치하면 아래 처럼 오류가 발생 함.

- 오류 화면








# 해결

ruby 버젼을 1.9로 변경하면 에러 없이 설치되고 동작 함.


xcode -> Preferences -> Downloads -> Command Line Tools 설치 

macport로 ruby1.9설치


#sudo port install ruby19

#sudo gem install jekyll


# 참고
설치이후에 아래처럼 실행하면, 로컬에서 페이지를 확인 할 수 있음

#jekyll --server

 
- 참고 화면


Posted by Gu Youn

댓글을 달아 주세요